2

I got an interVLAN configuration a.k.a 'Router on a Stick'. I can ping all the workstations with each other, except PC9 (refer to image). I did a simulation and found that the packet does not even leave the PC. Does anyone know what's going on? I've literally tried everything.

Thanks in advance.

PS. PT version: 7.2.2 Project screenshot Project (.pkt)

Configurations:

PC9

Link-local IPv6 Address.........: FE80::20A:41FF:FEA4:C69
 IP Address......................: 5.0.0.3
 Subnet Mask.....................: 255.0.0.0
 Default Gateway.................: 5.0.0.1

Laptop0

Link-local IPv6 Address.........: FE80::204:9AFF:FEA9:CA5A
 IP Address......................: 3.0.0.4
 Subnet Mask.....................: 255.0.0.0
 Default Gateway.................: 3.0.0.1

Laptop1

Link-local IPv6 Address.........: FE80::201:97FF:FE30:1E61
 IP Address......................: 1.0.0.5
 Subnet Mask.....................: 255.0.0.0
 Default Gateway.................: 1.0.0.1

Switch2

version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
 switchport access vlan 500
!
interface FastEthernet0/2
 switchport access vlan 300
!
interface FastEthernet0/3
 switchport access vlan 100
!
interface FastEthernet0/4
 switchport access vlan 200
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
 switchport access vlan 400
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
 switchport trunk allowed vlan 100,200,300,400,500
 switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end

Switch1

version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
 switchport access vlan 300
!
interface FastEthernet0/2
 switchport access vlan 100
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
 switchport trunk allowed vlan 100,200,300,400,500
 switchport mode trunk
!
interface FastEthernet0/24
 switchport trunk allowed vlan 100,200,300,400,500
 switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end

PC7

Link-local IPv6 Address.........: FE80::2D0:BAFF:FEB0:5E66
 IP Address......................: 1.0.0.4
 Subnet Mask.....................: 255.0.0.0
 Default Gateway.................: 1.0.0.1

PC8

Link-local IPv6 Address.........: FE80::260:70FF:FE25:2A79
 IP Address......................: 3.0.0.3
 Subnet Mask.....................: 255.0.0.0
 Default Gateway.................: 3.0.0.1

Switch0

version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
 switchport access vlan 100
!
interface FastEthernet0/2
 switchport access vlan 100
!
interface FastEthernet0/3
 switchport access vlan 300
!
interface FastEthernet0/4
 switchport access vlan 200
!
interface FastEthernet0/5
 switchport access vlan 200
!
interface FastEthernet0/6
 switchport access vlan 400
!
interface FastEthernet0/7
 switchport access vlan 500
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
 switchport trunk allowed vlan 100,200,300,400,500
 switchport mode trunk
!
interface GigabitEthernet0/1
 switchport trunk allowed vlan 100,200,300,400,500
 switchport mode trunk
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end

PC0

Link-local IPv6 Address.........: FE80::201:97FF:FEDE:66A4
 IP Address......................: 1.0.0.2
 Subnet Mask.....................: 255.0.0.0
 Default Gateway.................: 1.0.0.1

PC1

Link-local IPv6 Address.........: FE80::209:7CFF:FED7:7329
 IP Address......................: 1.0.0.3
 Subnet Mask.....................: 255.0.0.0
 Default Gateway.................: 1.0.0.1

PC2

Link-local IPv6 Address.........: FE80::230:A3FF:FE8A:3CAC
 IP Address......................: 3.0.0.2
 Subnet Mask.....................: 255.0.0.0
 Default Gateway.................: 3.0.0.1

PC3

Link-local IPv6 Address.........: FE80::260:70FF:FE9A:323B
 IP Address......................: 2.0.0.2
 Subnet Mask.....................: 255.0.0.0
 Default Gateway.................: 2.0.0.1

PC4

Link-local IPv6 Address.........: FE80::2D0:97FF:FEB6:BED1
 IP Address......................: 2.0.0.4
 Subnet Mask.....................: 255.0.0.0
 Default Gateway.................: 2.0.0.1

PC5

Link-local IPv6 Address.........: FE80::260:2FFF:FE65:3BE
 IP Address......................: 4.0.0.2
 Subnet Mask.....................: 255.0.0.0
 Default Gateway.................: 4.0.0.1

PC6

Link-local IPv6 Address.........: FE80::201:C9FF:FE32:3C3C
 IP Address......................: 5.0.0.2
 Subnet Mask.....................: 255.0.0.0
 Default Gateway.................: 5.0.0.1

Router0

version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX15242839-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/0.100
 encapsulation dot1Q 100
 ip address 1.0.0.1 255.0.0.0
!
interface GigabitEthernet0/0.200
 encapsulation dot1Q 200
 ip address 2.0.0.1 255.0.0.0
!
interface GigabitEthernet0/0.300
 encapsulation dot1Q 300
 ip address 3.0.0.1 255.0.0.0
!
interface GigabitEthernet0/0.400
 encapsulation dot1Q 400
 ip address 4.0.0.1 255.0.0.0
!
interface GigabitEthernet0/0.500
 encapsulation dot1Q 500
 ip address 5.0.0.1 255.0.0.0
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end
9
  • Check the MAC address table on Switch2. You can see that there is an issue with all of the access ports as you're only learning MAC's from your uplink. Hint: Just because you have set it to access a certain VLAN doesn't mean the port is an access port.
    – ditrapanij
    Commented Jan 2, 2020 at 22:46
  • Hi @ditrapanij! I'm not really sure if I understand you right. Here's the mac address-table of Switch2, perhaps you could be more with this? Mac Address Table ------------------------------------------- Vlan Mac Address Type Ports ---- ----------- -------- ----- 1 00d0.bcca.cd18 DYNAMIC Fa0/24 100 00d0.bcca.cd18 DYNAMIC Fa0/24 300 00d0.bcca.cd18 DYNAMIC Fa0/24
    – symonxd
    Commented Jan 2, 2020 at 22:58
  • I downloaded the file and had a look myself. Need to set Fast0/1 on Switch2 to be in access mode. Do this via switchport mode access
    – ditrapanij
    Commented Jan 2, 2020 at 22:59
  • @ditrapanij I just did what you suggested, and it didn't work. As far as I ain't wrong then it was already on access mode, thanks anyway :) Switch2 GUI
    – symonxd
    Commented Jan 2, 2020 at 23:06
  • @synmonxd, You will probably need to generate some traffic from the PC. Just try to ping your gateway. Probably also important to note, you'll need to create VLAN 500 on Switch1 too.
    – ditrapanij
    Commented Jan 2, 2020 at 23:13

1 Answer 1

1

If the echo request doesn't even leave the source, there's no connection (common broadcast domain) between the source and its default gateway - the ARP request for the gateway fails and that's that.

Use show mac address-table on each switch in turn to make sure that the switch sees both the source and the gateway in the desired VLAN.

Also make sure that VLANs are actually created on all switches that use or forward them.

3
  • 2
    Also make sure the VLAN is enabled on each switch. Type "show spanning-tree vlan 500" on each switch. They should all agree on the root switch.
    – Ron Trunk
    Commented Jan 2, 2020 at 22:46
  • 1
    Thank you so much, @RonTrunk! VLAN 500 was not created on all switches (Switch1).
    – symonxd
    Commented Jan 2, 2020 at 23:18
  • @RonTrunk The strange thing though is that I can ping Laptop1 (VLAN100) from PC5 (VLAN400). Where between those devices, there's Switch1, in which VLAN400 is not created. Perhaps you know the answer to this.
    – symonxd
    Commented Jan 2, 2020 at 23:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.