6

Cisco documentation states the following on forming channels:

SW1               SW2
----------------------------------------
On                 On              = Yes
Auto/Desirable     Desirable       = Yes
On/auto/desirable  Not configured  = No
On                 Desirable       = No
Auto/On            Auto            = No

It is to my understanding that Auto only responds to PAgP, but does not initiate the PAgP negotiation. But for some reason when testing both sides with Auto, the port channel comes up anyways.

SW1#show etherchannel summary 
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+----------------------------------------------

1      Po1(SU)           PAgP   Fa0/1(P) Fa0/2(P) 

My question is, shouldn't an Auto - Auto configuration fail? Why does this work?


Edit

Both switch configs

Switch1

Building configuration...

Current configuration : 1131 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SW1
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 channel-group 1 mode auto
 switchport mode trunk
!
interface FastEthernet0/2
 channel-group 1 mode auto
 switchport mode trunk
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Port-channel 1
 switchport mode trunk
!
interface Vlan1
 ip address 192.168.1.1 255.255.255.0
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end

Switch 2

Current configuration : 1134 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SW2
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 channel-group 1 mode auto
 switchport mode trunk
!
interface FastEthernet0/2
 channel-group 1 mode auto
 switchport mode trunk
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Port-channel 1
 switchport mode trunk
!
interface Vlan1
 ip address 192.168.1.2 255.255.255.0
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end

8
  • Can you post the configs of the two switches?
    – Ron Trunk
    Commented May 6, 2014 at 18:33
  • Did you bring the Etherchannel up in an active negotiation stage prior to setting the ports passively on both sides? I'm not sure why it would matter, so this is really just spitballing.
    – Ryan Foley
    Commented May 6, 2014 at 20:05
  • No, Auto on both sides. Then I brought up the interfaces. It might not "matter" since it just works, but I'm curious as to why it works even though official Cisco documentation says that it doesn't.
    – John Doe
    Commented May 6, 2014 at 20:53
  • 4
    @Ellie. This is some strange behavior for sure. I'm a bit suspicious of your code level potentially being a bit 'wonky'. Can you default int ra fa0/1 - 2 on one side and turn on debug pagp event before re-applying your interface configuration? Take note of the first line of the debug output: PAgP: Fa0/x enabling PAgp with mode .... Then on the other side. This is a long shot but I'm curious to see the output.
    – one.time
    Commented May 7, 2014 at 0:49
  • @Ellie It certainly shouldn't work. Try out one.time's recommendations.
    – Ryan Foley
    Commented May 7, 2014 at 10:30

1 Answer 1

3

As per default, etherchannel is running in "silent" mode. So ethch goes up at the first time, but if you try to disable/enable on side maybe ethch doesn't goes up again.

From CISCO CCO : non-silent —(Optional) If your switch is connected to a partner that is PAgP capable, configure the switch port for nonsilent operation when the port is in the auto or desirable mode. If you do not specify non-silent , silent is assumed. The silent setting is for connections to file servers or packet analyzers. This setting allows PAgP to operate, to attach the port to a channel group, and to use the port for transmission.

Not the answer you're looking for? Browse other questions tagged or ask your own question.