1

so for simplicity sake in testing this configuration, I have a sample project that looked like this: enter image description here breakdown:

Configurations

vlans configured on multilayer switch which is also vtp server:

vlan 2:

ip address 192.168.2.1 255.255.255.0

ip helper-address 192.168.3.1

vlan 3:

  • ip address 192.168.3.2 255.255.255.0

dhcp resides in vlan 3, static address 192.168.3.1

pool:

  • default gateway: 192.168.3.254

  • starting ip: 192.168.3.2

  • subnet mask: 255.255.255.0

  • maximum users: 200

all crossover connections are trunks (verified)

all straight connections are assigned to vlan 3 (verified)

pc 1 & 2 can properly receive a response from the DHCP server, but PC0 cannot.

I'm trying to get this to work while attempting to debug a 3 tier network design I'm working on for my networking 101 class. After multiple days trying to figure out why the traffic is not properly routing, I broke down the design trying to find the point of failure. As far as I have narrowed down, the issue is from intermediary switch (switch 1) which is part of the distribution layer but I am unable to grasp what is wrong with it's configuration (all ports trunk, vtp mode transparent).

I feel like I've missed something very fundamental in the routing setup, especially as I've gotten this configuration to work in the past, but I am unable to replicate the proper configuration.

//
//multilayer switch0
//
Building configuration...

Current configuration : 2249 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
!
!
ip routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
!
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
!
interface FastEthernet0/3
 switchport trunk encapsulation dot1q
!
interface FastEthernet0/4
 switchport trunk encapsulation dot1q
!
interface FastEthernet0/5
 switchport trunk encapsulation dot1q
!
interface FastEthernet0/6
 switchport trunk encapsulation dot1q
!
interface FastEthernet0/7
 switchport trunk encapsulation dot1q
!
interface FastEthernet0/8
 switchport trunk encapsulation dot1q
!
interface FastEthernet0/9
 switchport trunk encapsulation dot1q
!
interface FastEthernet0/10
 switchport trunk encapsulation dot1q
!
interface FastEthernet0/11
 switchport trunk encapsulation dot1q
!
interface FastEthernet0/12
 switchport trunk encapsulation dot1q
!
interface FastEthernet0/13
 switchport trunk encapsulation dot1q
!
interface FastEthernet0/14
 switchport trunk encapsulation dot1q
!
interface FastEthernet0/15
 switchport trunk encapsulation dot1q
!
interface FastEthernet0/16
 switchport trunk encapsulation dot1q
!
interface FastEthernet0/17
 switchport trunk encapsulation dot1q
!
interface FastEthernet0/18
 switchport trunk encapsulation dot1q
!
interface FastEthernet0/19
 switchport trunk encapsulation dot1q
!
interface FastEthernet0/20
 switchport trunk encapsulation dot1q
!
interface FastEthernet0/21
 switchport trunk encapsulation dot1q
!
interface FastEthernet0/22
 switchport trunk encapsulation dot1q
!
interface FastEthernet0/23
 switchport trunk encapsulation dot1q
!
interface FastEthernet0/24
 switchport trunk encapsulation dot1q
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan2
 mac-address 0010.1151.c701
 ip address 192.168.2.1 255.255.255.0
 ip helper-address 192.168.3.1
!
interface Vlan3
 mac-address 0010.1151.c702
 ip address 192.168.3.254 255.255.255.0
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end


//
//switch 0
//
Switch#sh running-config
Building configuration...

Current configuration : 2168 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport access vlan 3
 switchport mode access
!
interface FastEthernet0/2
 switchport access vlan 3
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 3
 switchport mode access
!
interface FastEthernet0/4
 switchport access vlan 3
 switchport mode access
!
interface FastEthernet0/5
 switchport access vlan 3
 switchport mode access
!
interface FastEthernet0/6
 switchport access vlan 3
 switchport mode access
!
interface FastEthernet0/7
 switchport access vlan 3
 switchport mode access
!
interface FastEthernet0/8
 switchport access vlan 3
 switchport mode access
!
interface FastEthernet0/9
 switchport access vlan 3
 switchport mode access
!
interface FastEthernet0/10
 switchport access vlan 3
 switchport mode access
!
interface FastEthernet0/11
 switchport access vlan 3
 switchport mode access
!
interface FastEthernet0/12
 switchport access vlan 3
 switchport mode access
!
interface FastEthernet0/13
 switchport access vlan 3
 switchport mode access
!
interface FastEthernet0/14
 switchport access vlan 3
 switchport mode access
!
interface FastEthernet0/15
 switchport access vlan 3
 switchport mode access
!
interface FastEthernet0/16
 switchport access vlan 3
 switchport mode access
!
interface FastEthernet0/17
 switchport access vlan 3
 switchport mode access
!
interface FastEthernet0/18
 switchport access vlan 3
 switchport mode access
!
interface FastEthernet0/19
 switchport access vlan 3
 switchport mode access
!
interface FastEthernet0/20
 switchport access vlan 3
 switchport mode access
!
interface FastEthernet0/21
 switchport access vlan 3
 switchport mode access
!
interface FastEthernet0/22
 switchport access vlan 3
 switchport mode access
!
interface FastEthernet0/23
!
interface FastEthernet0/24
 switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
end

//
//switch1
//
Building configuration...

Current configuration : 1620 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
vtp mode transparent
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport mode trunk
!
interface FastEthernet0/2
 switchport mode trunk
!
interface FastEthernet0/3
 switchport mode trunk
!
interface FastEthernet0/4
 switchport mode trunk
!
interface FastEthernet0/5
 switchport mode trunk
!
interface FastEthernet0/6
 switchport mode trunk
!
interface FastEthernet0/7
 switchport mode trunk
!
interface FastEthernet0/8
 switchport mode trunk
!
interface FastEthernet0/9
 switchport mode trunk
!
interface FastEthernet0/10
 switchport mode trunk
!
interface FastEthernet0/11
 switchport mode trunk
!
interface FastEthernet0/12
 switchport mode trunk
!
interface FastEthernet0/13
 switchport mode trunk
!
interface FastEthernet0/14
 switchport mode trunk
!
interface FastEthernet0/15
 switchport mode trunk
!
interface FastEthernet0/16
 switchport mode trunk
!
interface FastEthernet0/17
 switchport mode trunk
!
interface FastEthernet0/18
 switchport mode trunk
!
interface FastEthernet0/19
 switchport mode trunk
!
interface FastEthernet0/20
 switchport mode trunk
!
interface FastEthernet0/21
 switchport mode trunk
!
interface FastEthernet0/22
 switchport mode trunk
!
interface FastEthernet0/23
 switchport mode trunk
!
interface FastEthernet0/24
 switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
end

//
// switch 2
//
Building configuration...

Current configuration : 2168 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport access vlan 3
 switchport mode access
!
interface FastEthernet0/2
 switchport access vlan 2
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 2
 switchport mode access
!
interface FastEthernet0/4
 switchport access vlan 2
 switchport mode access
!
interface FastEthernet0/5
 switchport access vlan 2
 switchport mode access
!
interface FastEthernet0/6
 switchport access vlan 2
 switchport mode access
!
interface FastEthernet0/7
 switchport access vlan 2
 switchport mode access
!
interface FastEthernet0/8
 switchport access vlan 2
 switchport mode access
!
interface FastEthernet0/9
 switchport access vlan 2
 switchport mode access
!
interface FastEthernet0/10
 switchport access vlan 2
 switchport mode access
!
interface FastEthernet0/11
 switchport access vlan 2
 switchport mode access
!
interface FastEthernet0/12
 switchport access vlan 2
 switchport mode access
!
interface FastEthernet0/13
 switchport access vlan 2
 switchport mode access
!
interface FastEthernet0/14
 switchport access vlan 2
 switchport mode access
!
interface FastEthernet0/15
 switchport access vlan 2
 switchport mode access
!
interface FastEthernet0/16
 switchport access vlan 2
 switchport mode access
!
interface FastEthernet0/17
 switchport access vlan 2
 switchport mode access
!
interface FastEthernet0/18
 switchport access vlan 2
 switchport mode access
!
interface FastEthernet0/19
 switchport access vlan 2
 switchport mode access
!
interface FastEthernet0/20
 switchport access vlan 2
 switchport mode access
!
interface FastEthernet0/21
 switchport access vlan 2
 switchport mode access
!
interface FastEthernet0/22
 switchport access vlan 2
 switchport mode access
!
interface FastEthernet0/23
!
interface FastEthernet0/24
 switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
end

//
// switch 3
//
Building configuration...

Current configuration : 1118 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport access vlan 3
 switchport mode access
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
 switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
end
0

1 Answer 1

0

You either need to use VTP or manually configure the VLANs in global configuration, and you can optionally name them so that it makes sense:

Vlan 2
 name Name2
!
Vlan3
 name Name3
!
8
  • sorry those configs are from me trying literally anything to debug the routing problems, unfortunately even fixing them does not fix the issue (I've fixed the vlan 3 svi to point to 192.168.3.254 (I believe it "should" correspond with the the default gateway in the DHCP pool). there is no change. vlan 2 does have a pool but it doesn't seem relevant considering all the problem PC's are on vlan 3 (not touching inter-vlan routing until I have this sorted). Commented Jan 9, 2017 at 4:13
  • You need to give us the configurations you were thinking should work. By the way, I don't see where you have defined the VLANs on the switches, e.g. Vlan 3 in global configuration. Since you have VTP in transparent mode, you need to define the VLANs.
    – Ron Maupin
    Commented Jan 9, 2017 at 4:17
  • I believe all those issues are fixed by changing "int vlan 3" ip address 192.168.3.254 255.255.255.0, I've updated the configurations to reflect that. as to the switches, only switch 1 is transparent, I was under the impression that intermediary switches do not need to know about the Vlans as trunked frames are not detagged/retagged. (just tested this, and setting the vtp mode to client and verifying that the vlans sync'd properly does not fix the issue). appreciate your willingness to help Commented Jan 9, 2017 at 4:23
  • Did you try configuring the VLANs on the switches?
    – Ron Maupin
    Commented Jan 9, 2017 at 4:27
  • I stand corrected: after a few minutes with the new configuration, the frames started successfully passing through the intermediare switch (switch 1) and pc 0 is now properly communicating with the DHCP. I guess I was ill informed that intermediary switches could be transparent. thank you very much for your help Commented Jan 9, 2017 at 4:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.