-1

I have created a simple bus topology connecting 2 switches and a router, with each switch connected to their respective end devices through ordinary star topology. The switch model used was 3560-24PS and the router's being 2811.

Figure shows the network set-up

  1. I have created a VLAN for each switch and assigned the interfaces connected to the end devices to the same VLAN, to form a subnet. Namely, Switch 1 end devices are part of VLAN 10 and Switch 2 devices part of VLAN 20.

Figure shows the assignment of VLAN to the end-device connected interfaces of Switch 1 Figure shows the assignment of VLAN to the end-device connected interfaces of Switch 2

  1. Next, I configured the interfaces of each switch that is connected to each other, and the interface of switch 2 which is connected to the router to be trunk ports, and enabled traffic for both VLANs.

Figure shows configuration of trunk port for Switch 1's interface Figure shows configuration of trunk port for Switch 2's interface

  1. Then, I configured inter-VLAN routing in the router by configuring the router port interface connected to Switch 3 with 2 subinterfaces for each VLAN to act as each's default gateway.

Figures shows inter-VLAN routing configuration in the router

  1. Finally, I configured each end device of both VLANs with static IPs and their respective default gateways. The default gateway of devices of VLAN 10 are configured with the IP of its router subinterface: 192.168.10.1 and VLAN 20: 192.168.20.1

Nevertheless, when attempting to send a simple PDU between a device in VLAN 10 to a device in VLAN 20, it shows "Failed". I tried pinging too using the command prompt. Why is this the case? Is there something that I am missing or overlooking? I have been extensively looking up resources online for days and cracking my skull,and tried different steps but to no avail. Please do help me as I need to figure this out to successfully carry out inter-VLAN communication for my networking module assignment for university which is a lot more complex than this simple example.

Edit:

  1. Nodes(devices) of Switch 2(VLAN 20) can ping its default gateway but nodes of Switch 1(VLAN 10) cannot ping its default gateway. Moreover, as stated above, pinging between nodes of different VLANs don't work. Nevertheless, pinging between nodes of the same VLAN works.

  2. For more information, I have decided to provide the MAC address tables for each switch as a user have requested it.

MAC Address Table for Switch 1 & 2 respectively

  1. Zac67 has kindly informed me that he thinks VLAN is not configured for Switch 1 interfaces based on the MAC table I provided. I do not think this is the case. When I hover my mouse over the switch, a pop-up box shows up showing each port interface's information. It shows each port interface that is connected to end device nodes are configured with a VLAN.

Figure shows port interface information for Switch 1

From my understanding which hopefully isn't wrong, the reason the MAC address table of Switch 1 is incomplete(and also Switch 2) is that the table is dynamic. There is a timeout before the information resets(like in real-life switch MAC tables). So, it only showed the information of certain ports because I only pinged certain nodes and not all connected to the switch, leading to ARP discovery of only the nodes that had communicated with the switch. I did ping other nodes but it may ahve timed-out.

If my reasoning is way off, I am sorry.

9
  • Without knowing which hosts uses which MAC address, those outputs are useless. And PLEASE don't use screenshots for text. Instead, add them in text format, using the editor's {} preformat option.
    – Zac67
    Commented Jan 27 at 11:24
  • 2
    Please, never, ever use images for text. Simply copy the text and paste it into your post using the Preformatted text option ({}) that is right next to the image option that you used.
    – Ron Maupin
    Commented Jan 27 at 12:12
  • 1
    -1 for continuously posting text as pixel dumps.
    – Zac67
    Commented Jan 27 at 12:43
  • 1
    The VLAN that shows on an interface is not necessarily in the switch VLAN database. For any VLANs (except VLAN 1) that a switch must know about, use the global vlan <vlan number> command (you can add things like VLAN names here, which is an easy way to check that you actually created it in the VLAN database), and exit to write it to the VLAN database after you create the VLAN in the VLAN database.
    – Ron Maupin
    Commented Jan 27 at 12:44
  • Read this accepted answer for an explanation and how it solved such a problem.
    – Ron Maupin
    Commented Jan 27 at 13:09

2 Answers 2

1

First, you must create both VLANs on both switches, not just VLAN 10 on Switch 1 and VLAN 20 on Switch 2, but both VLANs on both switches:

vlan 10
 name Switch_1_VLAN
!
vlan 20
 name Switch_2_VLAN
!
exit !This is important to save the VLAN configuration

Next, you make sure that the trunk is configured on the interfaces of both switches where they connect to each other:

interface FastEthernet0/1
 switchport trunk encapsulation Dot1Q
 switchport trunk allowed vlan 10,20 !This is only to restrict the trunk to the two VLANs. It normally allows all VLANs.
 switchport mode trunk
 no shutdown
!

Next, do the same thing for the switch interface to the router:

interface FastEthernet0/2
 switchport trunk encapsulation Dot1Q
 switchport trunk allowed vlan 10,20 !This is only to restrict the trunk to the two VLANs. It normally allows all VLANs.
 switchport mode trunk
 no shutdown
!

Next, configure any access switch interfaces on each switch:

Switch 1:

interface FastEthernet0/x
 switchport access vlan 10
 switchport mode access
!

Switch 2:

interface FastEthernet0/x
 switchport access vlan 20
 switchport mode access
!

Last, create the router interfaces:

interface FastEthernet0/0
 no shutdown
!
interface FastEthernet0/0.10
 encapsulation Dot1Q 10
 ip address 192.168.10.1 255.255.255.0
 no shutdown
!
interface FastEthernet0/0.20
 encapsulation Dot1Q 20
 ip address 192.168.20.1 255.255.255.0
 no shutdown
!

If you still have a problem. then you must double-check the host configurations to make sure they are correct. Otherwise, it is an off-topic Packet Tracer bug.

1
  • thank you very much Ron. all my steps were the exact same as yours except the first one. I didn't create BOTH VLANs on BOTH switches. I created only VLAN 10 for Switch 1 and only VLAN 20 for Switch 2. I did not know that both VLANs must be created on each switch. That was the part that essentially blocked VLAN 10 nodes from communicating with its default gateway and nodes in VLAN 20.
    – Trineshen
    Commented Jan 27 at 14:54
1

First checks with VLAN-related problems:

  1. Have the VLANs been properly created on all switches? Assigning them without explicitly creating them (VLAN xx↵) doesn't always work.
  2. Can each node ping its default gateway and other required gateways? Or at least resolve the address using ARP?
  3. Check the switches' MAC tables to see if all relevant nodes show up in the desired VLAN.

Judging from the MAC table you've added, only one of the required VLANs has actually been created on each switch.

8
  • Thank you for your reply. 1. The VLANs are properly configured even though I didn't create them first before assigning them to the switch interfaces as the switch will automatically create a VLAN if the assigned VLAN doesn't exist. I do not think this is a problem. 2. Each node can ping its default gateway succesfully and also can ping other nodes within the same VLAN (which will be all the devices connected to its switch). But a node cannot ping another node from a different VLAN(which are all the devices that are connected to the switch other than theirs). (continue next comment)
    – Trineshen
    Commented Jan 27 at 10:59
  • continue from number 2) And may I know what do you mean by "resolve the address using ARP" as in Cisco Packet Tracer, ARP works by default without any need for configuration. 3. Lastly, the switches MAC address tables. I am not sure what to expect as I do not normally deal with it so I am attaching 2 pictures showing the MAC address table of each switch in the post(edited).
    – Trineshen
    Commented Jan 27 at 11:07
  • Please assist me by checking out my Packet Tracer file. You can have a look at my network and configurations, and test it with a hands-on approach.
    – Trineshen
    Commented Jan 27 at 11:24
  • 1
    Most of us don't use Packet Tracer and likely won't start with that for you. It's a tool used for CCNA certification and rarely professionally.
    – Zac67
    Commented Jan 27 at 11:27
  • I get it but I asked a question here in Stack Exchange as there will be someone who knows CPT well and maybe even uses it. Also, I would like to add that there is an inaccuracy in my statement to number 2. Only switch 2 nodes(VLAN 20) can ping its default gateway. Switch 1 nodes(VLAN 10) cannot ping its default gateway. Nevertheless, a node can ping other nodes within its VLAN. Perhaps you know what is the issue at hand?
    – Trineshen
    Commented Jan 27 at 11:39

Not the answer you're looking for? Browse other questions tagged or ask your own question.