1

I have installed OpenWRT onto my router (192.168.1.1). The router is connected to another ADSL router/modem (192.168.1.100) that provides the internet connection.

I am using the DHCP services on the OpenWRT router and I have set the WAN link up and can connect to the internet fine.

The problem is I can't access the original routers web control panel/ping it/talk to it. I can see it when doing a tracert for example, but can not access it in any way.

Here is my OpenWRT router's config. Can anyone help please?

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdc8:e507:defd::/48'

config interface 'lan'
        option ifname 'eth0.1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option dns '192.168.1.100'
        option gateway '192.168.1.100'
        option delegate '0'

config interface 'wan'
        option ifname 'eth0.2'
        option _orig_ifname 'eth0.2'
        option _orig_bridge 'false'
        option proto 'dhcp'
        option type 'bridge'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 2 3 4 5'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 1'
        option vid '2'

1 Answer 1

1

The problem is that your ADSL router is set to the same network as your local LAN. You are attempting to ARP for that router, however it is no longer on the same LAN as you.

I would suggest changing the IP address of the ADSL router to something like 192.168.0.100 and that should solve your problem. You can access it again by directly plugging into the ADSL router (you may have to set a static IP address on your laptop).

If that doesn't work, could you also update your question with the output of the traceroute?

2
  • Thanks! This fixed the issue! I am still not sure why this setup DID work when using DDWRT and stock firmware. But anyway - fixed now.
    – CJD
    Commented Nov 25, 2014 at 21:30
  • Not sure either. Maybe there were on different networks and you didn't know it? Or there is a possibility that DD-WRT does something special. Anyway, glad it works!
    – prateek61
    Commented Nov 25, 2014 at 21:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .